#精品
如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

错误类型:
浏览器错误
错误名称:
SSL版本过低错误
英文名称:
ERR_SSL_OBSOLETE_VERSION
错误描述:
TLS 1.0和TLS 1.1是旧标准,具有各种限制,无法支持许多现代互联网技术。因此,现在重点转向较新的TLS 1.2和1.3版本。

如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

当您运行WordPress网站时,确保访问者可以轻松访问它至关重要。因此,遇到错误消息和连接问题(例如 Chrome 错误警告)可能会非常令人沮丧。

在这篇文章中,我们将讨论Chrome中的ERR_SSL_OBSOLETE_VERSION警告,解释它发生的原因,并讨论您可以做些什么来解决它。

  1. TLS 1.0和1.1是什么(以及为什么不再支持它们)
  2. 网站上使用旧TLS版本的风险
  3. 如何查找网站正在运行的TLS版本
  4. 如何启用Chrome TLS 1.2或更高版本

TLS 1.0和1.1是什么(以及为什么不再支持它们)

从Google Chrome72 开始,一件关键的事情发生了变化:流行的浏览器开始弃用对旧版TLS版本的支持。这不应该是新闻,因为在 2019 年,谷歌和其他各种主要浏览器已经透露他们将弃用对TLS 1.0和TLS 1.1的支持。

这样做是为了增强浏览器的安全性和性能,并保护用户免受不安全站点的侵害。

TLS是“传输层安全”的缩写。它是一种加密安全协议, 负责保护在线传输的数据。换句话说,它保护在您网站的服务器和最终用户的浏览器之间发送的信息。

在这一点上,TLS 1.0和TLS 1.1是旧标准,具有各种限制,无法支持许多现代互联网技术。因此,现在重点转向较新的TLS 1.2和1.3版本。

这些提供了更好的安全性和更快的速度 ,并且已经成为几乎所有基于浏览器的连接的标准。

网站上使用旧TLS版本的风险

那么这对Chrome浏览器的未来意味着什么,更具体地说,对您网站的用户来说意味着什么?从Chrome 79开始,如果站点使用TLS 1.0或TLS 1.1,Chrome将显示警告通知,指示“不安全”连接。

如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

向使用TLS 1.0或1.1访问站点的用户显示新的安全指标(图片来源:chromium.org)

当访问者单击以获取更多信息时,他们会看到类似于以下内容的消息:

Your connection is not fully secure. This site uses an outdated security configuration, which may expose your information

——“您的连接并不完全安全。此站点使用过时的安全配置,这可能会暴露您的信息。”

自然,这条消息很可能会让许多潜在的访客望而却步。

这类似于您过去可能看到的其他类型的Chrome警告。但是,请务必注意,随着新版Chrome的发布,此特定通知只会变得更加严重。

例如,随着Chrome 81于2021年3月推出,与使用过时安全协议的网站的连接将被完全阻止。

如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

向使用TLS 1.0或1.1访问站点的用户显示警告消息(图片来源:chromium.org)

新的Chrome警告将是一个整页通知,说明浏览器尝试访问的页面并不完全安全。更重要的是,它将包含一个ERR_SSL_OBSOLETE_VERSION消息。警告所指的“过时版本”将是TLS 1.0或TLS 1.1。

这就是Google鼓励站点管理员立即启用TLS 1.2或更高版本的原因。执行此操作的过程将因您的托管服务提供商而异,我们将在稍后介绍。

但是,首先让我们谈谈如何确定此潜在问题是否与您的网站相关。

如何查找网站正在运行的TLS版本

如果您已经遇到ERR_SSL_OBSOLETE_VERSION警告,那么您就知道您的站点仅使用过时版本的TLS。例如,您在使用Google Search Console时可能会遇到此错误。

但是,如果您不确定您的网站启用了哪个版本的TLS,该怎么办?

幸运的是,有多种可能的方法可以找到这些信息。最简单的方法之一是使用Chrome DevTools。

您可以使用Command+Option+C  (在 Mac 上)或Control+Shift+C  (在 Windows 和 Linux 上)访问这些工具。然后,单击“安全” 选项卡:

如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

Chrome DevTools中的安全选项卡

Security Overview中,Connection部分应说明您的站点正在运行的TLS版本。如果该版本是1.2或1.3,如上例所示,您无需担心ERR_SSL_OBSOLETE_VERSION Chrome警告。如果版本是1.0或1.1,那么您有一些工作要做。

如何启用Chrome TLS 1.2或更高版本

为了防止ERR_SSL_OBSOLETE_VERSION通知,网站管理员需要在他们的网站上启用TLS 1.2或更高版本。

您不需要停用对1.0和1.1版的支持。相反,您只需确保您的网站通过Chrome TLS 1.2和/或1.3启用连接,以便使用较新浏览器版本的用户可以安全地访问您的网站。

根据您网站的主机和设置,您如何做到这一点会有很大差异。

您需要做的第一件事是验证您的托管服务器是否支持TLS 1.2(至少)。为此,您可以访问Qualys的SSL Server Test,然后输入您网站的主机名:

如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

Qualys SSL服务器测试工具

在结果中,查看 “TLS 1.2”和“TLS 1.3”的“配置”>“协议”:

如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知

协议部分,概述了支持的TLS版本

如果其中一个或两个都显示“是”,那么您就知道您的站点配置为使用TLS 1.2或更高版本。此时,您需要查阅托管服务提供商的文档或直接与他们联系,以了解如何在您的站点上启用该协议。

另一方面,如果“TLS 1.2”被标记为“否”,则可能无法启用该协议并阻止ERR_SSL_OBSOLETE_VERSION通知。在这种情况下,您会希望您的网络主机进行通信,以找出是否可以升级到一个不同的计划,在服务器上 配置为较新的TLS协议

或者,您也可以寻找新的托管服务提供商,以便轻松解决此问题。

小结

Google正在弃用对TLS 1.0和1.1的支持,这很重要,因为Chrome是网络上最常用的浏览器,占据浏览器市场份额的73%以上。因此,如果您的网站无法使用较新的TLS协议传输信息,您的访问者可能会面临ERR_SSL_OBSOLETE_VERSION Chrome警告。

避免该通知并确保访问者安全的最佳方法是启用对TLS 1.2或更高版本的支持。您可以使用Chrome DevTools 和Qualys的SSL Server Test来检查您的站点和服务器是否启用了这些协议。

打赏

感谢您的支持,我会继续努力的!

打开微信/支付宝扫一扫,即可进行扫码打赏哦,分享从这里开始,精彩与您同在
点赞 (0)

1 如果您喜欢本站,点击这儿不花一分钱捐赠本站,感谢支持!

2 可能会帮助到你: 使用帮助 | 报毒说明 | 进站必看 | 联系我们

3 修改版本安卓及电脑软件,加群提示为修改者自留,非本站信息,注意鉴别;

4 本网站部分资源来源于网络,仅供大家学习与参考,请于下载后24小时内删除;

5 若作商业用途,请联系原作者授权,若本站侵犯了您的权益请联系站长进行删除处理;

6 原创文章,作者:趣天亦,如若转载,请注明文章出处:https://qutianyi.com

趣天亦资源网 WordPress错误 如何修复Chrome浏览器ERR_SSL_OBSOLETE_VERSION警告通知 https://qutianyi.com/19093.html

常见问题
  • 本站所有资源版权均属于原作者所有,这里所提供资源均只能用于参考学习用,请勿直接商用。若由于商用引起版权纠纷,一切责任均由使用者承担。任何单位或个人认为本站部分内容可能涉嫌侵犯其合法权益,请及时和我们联系。我们将会第一时间移除相关涉嫌侵权的内容。
查看详情

相关文章

发表评论
暂无评论
官方客服团队

为您解决烦忧 - 24小时在线 专业服务